Yamaha Star Stryker banner
1 - 9 of 9 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
so just hit 132,000 miles and decided to do a radiator flush and all that jazz.. two day later I noticed a small drip on body cok.. followed previously threads on this issue and replaced o rings.. sure enough 3 days later bike over heating light goes off.. check coolant fluid , was pretty much empty.. after 6hr of letting bike sit I refill , and get rid of air , and small drip shows on drain ****.. after 5 min or so , no leak.. ran the bike no issue.. 5 days later heating up.. noticed leak came back on drain ****.. checked every hose and radiator no issues.. now drain **** leaks at random, but I am losing coolant. since I am in area where Harley rules, no one knows or wants to work on my bike.. thought about replacing water pump , but maybe someone has a hit or advise what to look for, before I Crack the crank case.. oh yeah oil is not mixing with coolant.. and fan is turning on when I am low or heating up..
 

·
Administrator
‘13 Stryker
Joined
·
1,154 Posts
It sounds like you have an airlock and didn’t put enough coolant in. My draincock dripped randomly from new and still gives me a droplet or three every year. I have 37k miles on mine and haven’t replaced the coolant yet but added about 2 cups maybe in 8 years. The big question is where are you loosing coolant from? I did have to replace my rad cap as it wasn’t opening correctly. I’d check that first as that will cause overheating issues could also not let it draw coolant from reservoir once air is cleared.
 

·
Registered
Joined
·
2,482 Posts
If it isn't on the garage floor only options are burning it or maybe something like the resouvier hose didn't get reconnected. Visually check. You could also have a puncture in the radiator itself or one of the hoses that only leaks under pressure and then probably won't show in the garage.
After that, all you can do is drain again, measure what came out, reference the owners manual and then make sure you put in correct amount.

Shouldn't have been any issues with a simple drain and fill but things happen. If still baffled, look up leak dye tester and add to coolant, ride, come home and look over bike with black light. You'll see it if it is leaking!!
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #4 ·
If it isn't on the garage floor only options are burning it or maybe something like the resouvier hose didn't get reconnected. Visually check. You could also have a puncture in the radiator itself or one of the hoses that only leaks under pressure and then probably won't show in the garage.
After that, all you can do is drain again, measure what came out, reference the owners manual and then make sure you put in correct amount.

Shouldn't have been any issues with a simple drain and fill but things happen. If still baffled, look up leak dye tester and add to coolant, ride, come home and look over bike with black light. You'll see it if it is leaking!!
worried I might find other stuff light up with the black light..lol..
 

·
Administrator
‘13 Stryker
Joined
·
1,154 Posts
View attachment 124276 this is how much coolant I drop, then it stops 5 min after I get to where ever I am going
So it leaks while sitting cold then after you fire it up and drive it— it stops? And you say it is definitely coming from the draincock. I would think possibly a nicked O-ring from install, I swear I read of that happening to someone in here?
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #7 ·
draincock 100% ...cold will not drip unless I remove it put it back in.. today it actually dripped while riding.... already followed previously forum of o-ring replacement, .. just ordered a new draincovk , new o rings, and new radiator cap.. just trying to eliminate every other issue before I Crack open the engine case to switch out water pump.. have yet to find any YouTube or forum where someone opens up the engine for the waterpump
 

·
Administrator
Joined
·
4,750 Posts
so just hit 132,000 miles and decided to do a radiator flush and all that jazz.. two day later I noticed a small drip on body cok.. followed previously threads on this issue and replaced o rings.. sure enough 3 days later bike over heating light goes off.. check coolant fluid , was pretty much empty.. after 6hr of letting bike sit I refill , and get rid of air , and small drip shows on drain *.. after 5 min or so , no leak.. ran the bike no issue.. 5 days later heating up.. noticed leak came back on drain *.. checked every hose and radiator no issues.. now drain **** leaks at random, but I am losing coolant. since I am in area where Harley rules, no one knows or wants to work on my bike.. thought about replacing water pump , but maybe someone has a hit or advise what to look for, before I Crack the crank case.. oh yeah oil is not mixing with coolant.. and fan is turning on when I am low or heating up..
Ok so all I have to say is WOW 132,000 miles. Sorry I cannot help with your problem
 

·
Registered
Joined
·
46 Posts
Discussion Starter · #9 ·
so little update, I changed thermostat no change on the drip.. I installed new radiator cap, now bike only dirps very little when it warms up.. still trouble shooting bike.. I don't want to Crack open that case.. I got two options left, change out hoses, or pour some blue devil casket sealer..
 
1 - 9 of 9 Posts
Top