Yamaha Star Stryker banner

1 - 6 of 6 Posts

·
Registered
Joined
·
671 Posts
Discussion Starter #1
My check engine light came on the other day but it was on and off my whole way home. I assumed it was oil but my oil is good. I found how to check codes, but it didn't quite go as expected.

The instruction said to hold RESET and turn the ignition on until DIAG appears on the screen. But as soon as I turn the ignition on, I am getting "22" on the screen. If I hold SELECT and RESET together while turning the ignition on, I'll get to the DIAG screen but there are no CEL codes, just the engine diagnostics. If I continue to hold RESET and press/hold SELECT after the code turns on, it appears to have reset the CEL.

So I am assuming the CEL is code 22 which is the air temp sensor and I went ahead and ordered the sensor, but am hoping for some clarification that this is correct.

The only reason I can think of as to why the instructions are different is because of my Digital Guard Dog ignition. I don't have an ignition switch & kill switch anymore. The kill switch is rewired as the ignition switch, so I can't turn the ignition on with the kill switch off. Not sure if that makes a difference...

My bike is a 2012 Stryker
 

·
Registered
Joined
·
2,432 Posts
Don't know about the DGD but for the sensor, double check that the wiring is tight. Disconnect, lube & reconnect. Have not heard of them going bad but then again everything breaks eventually...
 

·
Registered
Joined
·
671 Posts
Discussion Starter #3
I unplugged, cleaned, lubed, and checked over the connector. I wouldn't doubt if it was bad because I've had it on and off so many times and never cared to be careful with it (didn't realize it was important enough to throw a CEL... lol). A new one was only $20 so we'll see what happens.
 

·
Registered
Joined
·
27 Posts
klarowe or billyd66,
I think I have the same problem as you did. Can you tell me which wiring or connector you are referring to? Were you able to fix the CEL?






thanks,
StrykerOut
 

·
Registered
Joined
·
4 Posts
Emmm i don't think about the DGD yet for the sensor, twofold watch that the wiring is tight. Detach, lube and reconnect. Have not known about them turning sour however on the other hand everything breaks in the long run...
 
1 - 6 of 6 Posts
Top