Yamaha Star Stryker banner

1 - 14 of 14 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
Installed the Cobra slip on 2 days ago! I am getting alot of popping on harder decell. Do i have to reset the computer so the 02 readjusts? Love the sound of the pipe..
 

Attachments

·
Registered
Joined
·
135 Posts
You'll need a programmer. When I put my Cobra pipes on I got a lot of popping on decel. I tried disconnecting the battery for a couple hours hoping it would make the ECU reset, but it didn't work. After I installed the Cobra PowrPro programmer I had no more popping. :)
 

·
Registered
Joined
·
1,089 Posts
clar2001 said:
well you can disconnect your negative battery cable for about 30min then your ecu will relearn your driving , if the popping is still there then you will need a programmer.
How often does that work?
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #9 ·
I unhooked the battery for 15 minutes. Went for a ride and it's nit popping as bad. It's something I can deal with for a while! Sounds good! Lol
 

·
Registered
Joined
·
1,004 Posts
Slip-on looks good, but a little long! Strange beacuse the other guy on here who installed the slip-on didn't seem to be as long. Maybe its just me" :)
 

·
Registered
Joined
·
81 Posts
looking at same pipes. i was told by cobra that this is a mild mod and no need for programmers, etc... look good. ordering mine now.
custom cruisers $199.99 shipped.
 

·
Hero Member
Joined
·
2,671 Posts
claytonandson said:
looking at same pipes. i was told by cobra that this is a mild mod and no need for programmers, etc... look good. ordering mine now.
custom cruisers $199.99 shipped.
that's a good price! what's their website? when i did a google search for "Custom Cruisers" it came up with a company in the UK.
 
1 - 14 of 14 Posts
Top