Yamaha Star Stryker banner

1 - 20 of 76 Posts

·
Registered
Joined
·
860 Posts
Discussion Starter · #1 ·
I think some clarification on the Cobra FI2000R PowerPro Fuel Tuner is in order. ONLY if you have this fuel tuner installed, answer these questions:

What issues have you had with this tuner?

What mods do you have?

Did the issue get fixed?

Do you regret getting it?

Since reading through this forum, I have discovered there is confusion on this tuner. This may help those of us who have or going to get it.

Thanks you guys!
 

·
Registered
Joined
·
378 Posts
Re: Issues with the Cobra FI2000R PowerPro Fuel Tuner (Not the Power Commander)

The only issue I've had with this tuner was the fact that the low speed chugging, that seems to be common with this bike, was not immediately fixed. I expected that to go away as soon as I put the tuner on. With a little tuning on the 1st pod, however, it is running pretty good and I have no complaints. I'm running the Cobra Swept exhaust and a spike air intake. I'd get it again.
 

·
Registered
Joined
·
1,341 Posts
Re: Issues with the Cobra FI2000R PowerPro Fuel Tuner (Not the Power Commander)

I think some clarification on the Cobra FI2000R PowerPro Fuel Tuner is in order. ONLY if you have this fuel tuner installed, answer these questions:
What issues have you had with this tuner?
Consistent backfiring on decel at speeds higher than 50 mph and the bike misses when cruising in second gear at ~25 mph.

What mods do you have?
V&H Twin Slash Staggered Exhaust

Did the issue get fixed?
Not yet, just installed in Thursday. Gonna call Cobra today

Do you regret getting it?
Not yet. Hope there is a solution that doesn't involve returning the PowerPro.
 

·
Registered
Joined
·
404 Posts
Re: Issues with the Cobra FI2000R PowerPro Fuel Tuner (Not the Power Commander)

midlifecrisis said:
I think some clarification on the Cobra FI2000R PowerPro Fuel Tuner is in order. ONLY if you have this fuel tuner installed, answer these questions:
What issues have you had with this tuner?
Consistent backfiring on decel at speeds higher than 50 mph and the bike misses when cruising in second gear at ~25 mph.

What mods do you have?
V&H Twin Slash Staggered Exhaust

Did the issue get fixed?
Not yet, just installed in Thursday. Gonna call Cobra today

Do you regret getting it?
Not yet. Hope there is a solution that doesn't involve returning the PowerPro.
Just in case you haven't followed my thread - I've got the same pipes and the same issues, and Cobra has replaced the unit entirely and it did no good at all. Still has the exact same issues. Starting to look like design flaw to me.
 

·
Registered
Joined
·
378 Posts
Re: Issues with the Cobra FI2000R PowerPro Fuel Tuner (Not the Power Commander)

I'm not sure that we are all talking about the same tuner. The Fi2000R is not the auto tune model. The Fi2000R has three set screw type settings (pods) that when manually adjusted change the way the bike runs. If I'm wrong I apologize, but I just wanted to make sure that we are all on the same page :)
 

·
Registered
Joined
·
124 Posts
Re: Issues with the Cobra FI2000R PowerPro Fuel Tuner (Not the Power Commander)

oh sorry mine is the auto tuner.... sorry
 

·
Registered
Joined
·
860 Posts
Discussion Starter · #7 ·
Re: Issues with the Cobra FI2000R PowerPro Fuel Tuner (Not the Power Commander)

Fujums said:
I'm not sure that we are all talking about the same tuner. The Fi2000R is not the auto tune model. The Fi2000R has three set screw type settings (pods) that when manually adjusted change the way the bike runs. If I'm wrong I apologize, but I just wanted to make sure that we are all on the same page :)
You are correct... the "R" should have been left off... but the "PowerPro" kinda gives it away... I should have added "CVT" to better clarify. Thanks for catching that!

Dave
 

·
Registered
Joined
·
4,199 Posts
just finished the install of the auto tuner and Cobra air intake, holy crap! very noticeable power gain and low range torque. mmediately took out chugging and what appears to be occasional misfires, put 60 miles on it this morning, i love this upgrade!
 

·
Registered
Joined
·
1,568 Posts
StrykenShane said:
just finished the install of the auto tuner and Cobra air intake, holy crap! very noticeable power gain and low range torque. mmediately took out chugging and what appears to be occasional misfires, put 60 miles on it this morning, i love this upgrade!
Nice StykenShane, I have the same setup just in chrome, Cobra Swepts, Cobra PowerFlo intake and the PowerPro Autotune and love what the power mod has done to my bike, I might get a pop every once in a while but no issues like others have seen using the Vance & Hines and other intakes. Then again since the whole package is cobra, I really would not expect to see issues and one of the main reasons I went this route.
 

·
Registered
Joined
·
132 Posts
I have the Cobra Swept Exhaust with the Fi2000 (the one with 3 pots that can be tuned) With the Cobra settings of 2-5-5 I had a lot of backfire and chugging on 1st gear almost like it was going to die at any moment. Iv'e adjusted the green pot little by little like the manual says and now I am at 6-5-5. The bike runs better on these settings but I still get a pop on deceleration between 37-43 mph on 2nd, 3rd, and sometimes 4th gears but nothing like when it was at the factory settings.

My question is: If the Cobra factory settings for the Fi2000 are 2-5-5 for the Stryker with a full exhaust, why did I have to adjust the first pot from 2 all the way to 6?
 

·
Registered
Joined
·
4,199 Posts
Bozzly said:
StrykenShane said:
just finished the install of the auto tuner and Cobra air intake, holy crap! very noticeable power gain and low range torque. mmediately took out chugging and what appears to be occasional misfires, put 60 miles on it this morning, i love this upgrade!
Nice StykenShane, I have the same setup just in chrome, Cobra Swepts, Cobra PowerFlo intake and the PowerPro Autotune and love what the power mod has done to my bike, I might get a pop every once in a while but no issues like others have seen using the Vance & Hines and other intakes. Then again since the whole package is cobra, I really would not expect to see issues and one of the main reasons I went this route.
Same here, waited awhile to see the feedback on the tuner and intake, your post was the main reason I did this
 

·
Registered
Joined
·
1,568 Posts
StrykenShane said:
Bozzly said:
StrykenShane said:
just finished the install of the auto tuner and Cobra air intake, holy crap! very noticeable power gain and low range torque. mmediately took out chugging and what appears to be occasional misfires, put 60 miles on it this morning, i love this upgrade!
Nice StykenShane, I have the same setup just in chrome, Cobra Swepts, Cobra PowerFlo intake and the PowerPro Autotune and love what the power mod has done to my bike, I might get a pop every once in a while but no issues like others have seen using the Vance & Hines and other intakes. Then again since the whole package is cobra, I really would not expect to see issues and one of the main reasons I went this route.
Same here, waited awhile to see the feedback on the tuner and intake, your post was the main reason I did this
Glad I was able to help and even happier that you got good results as I have with this setup.
 

·
Registered
Joined
·
1,568 Posts
Stryk-ED said:
I have the Cobra Swept Exhaust with the Fi2000 (the one with 3 pots that can be tuned) With the Cobra settings of 2-5-5 I had a lot of backfire and chugging on 1st gear almost like it was going to die at any moment. Iv'e adjusted the green pot little by little like the manual says and now I am at 6-5-5. The bike runs better on these settings but I still get a pop on deceleration between 37-43 mph on 2nd, 3rd, and sometimes 4th gears but nothing like when it was at the factory settings.

My question is: If the Cobra factory settings for the Fi2000 are 2-5-5 for the Stryker with a full exhaust, why did I have to adjust the first pot from 2 all the way to 6?
There is another thread about this processor, oh I see you already found it.. ;)
 

·
Registered
Joined
·
132 Posts
Bozzly said:
Stryk-ED said:
I have the Cobra Swept Exhaust with the Fi2000 (the one with 3 pots that can be tuned) With the Cobra settings of 2-5-5 I had a lot of backfire and chugging on 1st gear almost like it was going to die at any moment. Iv'e adjusted the green pot little by little like the manual says and now I am at 6-5-5. The bike runs better on these settings but I still get a pop on deceleration between 37-43 mph on 2nd, 3rd, and sometimes 4th gears but nothing like when it was at the factory settings.

My question is: If the Cobra factory settings for the Fi2000 are 2-5-5 for the Stryker with a full exhaust, why did I have to adjust the first pot from 2 all the way to 6?
There is another thread about this processor, oh I see you already found it.. ;)
Yeah I was confused about the different processors....thanks
 

·
Registered
Joined
·
15 Posts
I have installed the Auto Tuner i2000 on my stryker and am now considering witch Pipes to buy.If I buy 2 into 2 pipes Do I need a different wiring harness with Two O2 sensor plugs or do I still just use just one O2 plug as with the stock pipes ????
 

·
Registered
Joined
·
3,133 Posts
I am having the same backfire issues with the same V & H pipes and cobra auto tuner.
A large percentage of problems appear to be on bikes with Vance and Hines pipes.
I don't think the processor likes them???
I had a few issues with my cobra processor, cobra power flow intake, and cobra swept pipes
The pipes have a cross-over between them with only one O2 sensor but cobra even said (Over the phone) to disconnect the sensor all together.
The other problem was caused by me being cheap and not replacing the gaskets when I installed the pipes which caused a "Hiccup" at speed when neither on or off the throttle.
That's it.
The biggest solution PERIOD for the low speed "chugging" is to replace the 31 tooth front pulley with the 30 tooth front pulley off the Vstar 1300... No more chugging
 

·
Registered
Joined
·
623 Posts
I have the cobra auto tuner, cobra intake and vance and hince big radius 2/2 exhaust. When I'm riding at highway speeds up to 80 mph it runs fine but it seems like once I hit 80 mph it has a hick up and a slight delay of power to the bike but picks right back up. Any ideas what's causing this problem?

I haven't pushed it to much farther for an extended period of time for the slight fear of the highway patrol and a speeding ticket.
 
1 - 20 of 76 Posts
Top