Yamaha Star Stryker banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have Had this Stryker for a couple of months now and assumed I had a Fuel problem (getting about 140km per tank) Works out that the speedo is off heaps and I get about 240kms per tank by GPs.
I have checked and found that the speed that I am actually travelling is fine but the Odometer reading is out.
Has anybody had that problem. New Gauge $900+AUS. Open for options and ideas.
 

·
Registered
2012 Stryker
Joined
·
107 Posts
Could be that your odometer is reading in miles and not km. 140 miles is about 225kms. Set your gps to miles to see if the distances match.
 

·
Registered
‘13 Stryker
Joined
·
887 Posts
I have Had this Stryker for a couple of months now and assumed I had a Fuel problem (getting about 140km per tank) Works out that the speedo is off heaps and I get about 240kms per tank by GPs.
I have checked and found that the speed that I am actually travelling is fine but the Odometer reading is out.
Has anybody had that problem. New Gauge $900+AUS. Open for options and ideas.
If I ride aggressive 80+ and fast pullouts I’m lucky to get 155km per tank, If I drive easy 45-55 like on a bike cruise-( my wife calls it Normal- haha- I can easily get 255 km a tank before I need to fuel up and that’s two up with 240 rear tire and Ivan’s flash.

I know there is a few speedo correctors out there, I can’t remember the popular ones for our bike of top of my head. Do a speedo calibration search.
 

·
Registered
2012 Stryker
Joined
·
107 Posts
He said speed reading is spot on, odometer is off. Speedo calibration will do nothing to fix his issue.
 
1 - 4 of 4 Posts
Top